lkml.org 
[lkml]   [2017]   [Dec]   [4]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
SubjectRe: [PATCH 4/6] staging: pi433: Rename enum optionOnOff in rf69_enum.h
From
Date


Am 04.12.2017 um 21:42 schrieb Simon Sandström:
> On Mon, Dec 04, 2017 at 09:22:06PM +0200, Marcus Wolf wrote:
>>
>>
>> Am 04.12.2017 um 21:15 schrieb Dan Carpenter:
>>>
>>> That's a bad name, because it doesn't just enable it also disables.
>>> Please split them.
>>>
>>> regards,
>>> dan carpenter
>>>
>>>
>>
>> Same applies to all other stuff, that's using optionOnOff:
>> rf69_set_sync_enable(optionOn/Off) enables and disbales sync,
>> rf69_set_crc_enable(optionOn/Off) enables and disables crc,
>> ...
>>
>> In my opinion, if we want perfect clarity, we should stay with optionOnOff.
>> If we are ok, if rf69_set_sync_enable(false) disables sync,
>> in my opinion, we also have to be ok, if rf69_set_amp_X_enable(false)
>> disables the amp.
>>
>> Cheers,
>> Marcus
>
> Hi,
>
> I agree with Dan. rf69_enable_sync() / rf69_disable_sync() is clear. If
> there are more functions like this (e.g. for crc) then we'll just split
> those functions as well.
>
> If you really want one single function for enabling/disabling then I
> think that you need to find a better name. Something like
> rf69_set_sync_operation(bool), rf69_set_crc_operation(bool), etc.
>
>
> Regards,
> Simon
>

Hi Simon, hi Dan,

if you both are of the same opinion, for me, it's fine, if we go with
two functions.

But I don't get the advantage, if we split approx. 10 functions, to get
rid of enum optionOnOff.

Keep in mind, that if you split the functions, in the interface
implementation you also need more code:

SET_CHECKED(rf69_set_sync_enable(dev->spi, rx_cfg->enable_sync));

will have to be converted in something like

if (rx_cfg->enable_sync)
SET_CHECKED(rf69_set_sync_enbable(dev->spi);
else
SET_CHECKED(rf69_set_sync_disable(dev->spi);


For me, it is important, that the configuration, you'll have to write in
the user space program (aka fill out the config struct) will be 100%
non-ambigious and easy to read.

Cheers,
Marcus

\
 
 \ /
  Last update: 2017-12-04 20:59    [W:0.738 / U:0.132 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site