[lkml]   [2017]   [Dec]   [27]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectRe: [RFC V7 2/2] OPP: Allow "opp-hz" and "opp-microvolt" to contain magic values
On Tue, Dec 26, 2017 at 10:45 PM, Viresh Kumar <> wrote:
> On 26-12-17, 14:23, Rob Herring wrote:
>> > cpu_opp_table: cpu_opp_table {
>> > compatible = "operating-points-v2";
>> > opp-shared;
>> >
>> > opp00 {
>> > opp-hz = /bits/ 64 <208000000>;
>> > clock-latency-ns = <500000>;
>> > power-domain-opp = <&domain_opp_1>;
>> What is this? opp00 here is not a device. One OPP should not point to
>> another. "power-domain-opp" is only supposed to appear in devices
>> alongside power-domains properties.
> There are two type of devices:
> A.) With fixed performance state requirements and they will have the
> new "required-opp" property in the device node itself as you said.
> B.) Devices which can do DVFS (CPU, MMC, LCD, etc) and those may need
> a different performance state of the domain for their individual OPPs
> and so we can't have this property in the device all the time.
> Does this make sense ?

No. From the definition for power-domain-opp

"+- power-domain-opp: This contains phandle to one of the OPP nodes of
the master
+ power domain. This specifies the minimum required OPP of the master
domain for
+ the functioning of the device in this OPP (where this property is present).
+ This property can only be set for a device if the device node contains the
+ "power-domains" property. Also, either all or none of the OPP nodes in an OPP
+ table should have it set."

In the above example, you are violating the next to last sentence.

Though, I'm now confused by what the last sentence means.


 \ /
  Last update: 2017-12-27 22:37    [W:0.062 / U:10.464 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site