lkml.org 
[lkml]   [2017]   [Dec]   [18]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
Subject[PATCH V8 0/3] OPP: Allow OPP table to be used for power-domains
Date
Hi,

Now that the performance state of PM domains are supported by the kernel
(merged in linux-next), I am trying once again to define the bindings
which we dropped until the code is merged first.

Summary:

Power-domains can also have their active states and this patchset
enhances the OPP binding to define those.

The power domains can use the OPP bindings mostly as is. Though there
are some changes required to support special cases:

- Allow "operating-points-v2" to contain multiple phandles for power
domain providers providing multiple domains.

- A new property "required-opp" is added for the devices to specify the
minimum required OPP of the master domain or any other type of device.

- Allow some of the OPP properties to accept magic values (firmware
dependent) as the OS doesn't know the real freq/voltage values.

V7->V8:
- V7 1/2 divided into two patches. 1/3 is unchanged from V7.
- 2/3 renamed the property from "power-domain-opp" to "required-opp", as
suggested by Rob.
- Added Ulf's reviewed-by for 1/3 and 3/3.

--
viresh

Viresh Kumar (3):
OPP: Allow OPP table to be used for power-domains
OPP: Introduce "required-opp" property
OPP: Allow "opp-hz" and "opp-microvolt" to contain magic values

Documentation/devicetree/bindings/opp/opp.txt | 19 +++++++
.../devicetree/bindings/power/power_domain.txt | 65 ++++++++++++++++++++++
2 files changed, 84 insertions(+)

--
2.15.0.194.g9af6a3dea062

\
 
 \ /
  Last update: 2017-12-18 11:23    [W:0.179 / U:0.304 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site