lkml.org 
[lkml]   [2017]   [Nov]   [30]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
Subject[PATCH v2 00/10] trace-cmd: Refactoring trace_record()
Date
The following series of patches is a refactoring of trace_record() trying to
reduce as much as possible its complexity but, at the same time, without making
risky changes. All the patches are relatively small and potentially no-brainer
steps towards the final shape of the code.

The rationale for this effort is to make the code much easier to maintain.

Vladislav Valtchev (VMware) (10):
trace-cmd: Extract parse_record_options() from trace_record()
trace-cmd: Replacing cmd flags w/ a trace_cmd enum
trace-cmd: Extracting record_trace()
trace-cmd: Rename trace_profile() to do_trace_profile()
trace-cmd: Making start,extract,stream,profile separate funcs
trace-cmd: Extr. profile-specific code from record_trace
trace-cmd: Mov init_common_record_context in parse_record_options
trace-cmd: Introducing get_trace_cmd_type()
trace-cmd: Extract finalize_record_trace()
trace-cmd: Fork record_trace() for the extract case

trace-cmd.c | 8 +-
trace-local.h | 10 +-
trace-profile.c | 2 +-
trace-read.c | 2 +-
trace-record.c | 640 +++++++++++++++++++++++++++++++++-----------------------
5 files changed, 390 insertions(+), 272 deletions(-)

--
2.14.1

\
 
 \ /
  Last update: 2017-11-30 14:21    [W:1.083 / U:0.840 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site