lkml.org 
[lkml]   [2017]   [Oct]   [3]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
SubjectRe: [PATCH 1/3] scsi: ufs: Change HCI marco to actual bit position
From
Date
Hi Bart,

On 10/02/2017 10:11 PM, Bart Van Assche wrote:
> On Sat, 2017-09-30 at 11:52 +0530, Alim Akhtar wrote:
>> Currently UFS HCI uses UFS_BIT() macro to get various bit
>> position for the hardware registers status bits. Which makes
>> code longer instead of shorter. This macro does not improve
>> code readability as well.
>> Lets re-write these macro definition with the actual bit position.
>
> Can the three patches in this series be combined into a single patch?
>
Since UFS_BIT() used in qcom-ufs driver as well, so I thought of keeping
them in separate patches. This way "git bisect" will work all the time.

>> -#define UFS_BIT(x) (1L << (x))
>> [ ... ]
>> +#define UFS_BIT(x) (1L << (x))
>
> If you want to keep the three patches separate, please make sure that this
> patch does not modify the UFS_BIT() definition. Please also fix the spelling
> of the title of this patch (marco -> macro).
>
Ok, will fix these
> Thanks,
>
> Bart.
>

\
 
 \ /
  Last update: 2017-10-03 10:37    [W:2.183 / U:2.436 seconds]
©2003-2017 Jasper Spaans. hosted at Digital OceanAdvertise on this site