lkml.org 
[lkml]   [2017]   [Oct]   [26]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: 4.13 (and probably all recent) kernels refuse to boot on one Nokia N950, work or another
Hi,

On Thu, Oct 26, 2017 at 11:57:34AM +0200, Pavel Machek wrote:
> On Thu 2017-10-26 11:31:15, Sebastian Reichel wrote:
> > Hi,
> >
> > On Thu, Oct 26, 2017 at 11:13:26AM +0200, Pavel Machek wrote:
> > > On Wed 2017-10-25 14:28:07, Tony Lindgren wrote:
> > > > * Pavel Machek <pavel@ucw.cz> [171025 13:36]:
> > > > > Hi!
> > > > >
> > > > > ...hardware should be identical. 3.5.3-nemo kernel seems to work on
> > > > > both. 4.13-rc2 with display and clock patches boots on phone "S", but
> > > > > does not on phone "P"; nothing nothing is received on serial port.
> > > > >
> > > > > There is some difference in the bootloaders: S's bootloader provides
> > > > > lots of debug info, P's is silent. R&D settings do _not_ have
> > > > > influence on bootloader. We know P's serial works, as 3.5.3 kernel
> > > > > prints "Uncompressing linux...booting" there.
> > > > >
> > > > > I'll need to return "S" phone and serial cable tommorow. If you have
> > > > > any ideas, let me know.
> > > >
> > > > If you get nothing out of the uart, chances are the pins are
> > > > not muxed for the uart in nolo and maybe kernel dts is missing the
> > > > pinctrl entries for uart?
> > > >
> > > > Also try booting with mem=512M@0x80000000 or 256M or 768M. Maybe the
> > > > memory is different size or partially broken?
> > >
> > > Uhuh. It looks like "P" nokia really wants initrd, otherwise it will
> > > not boot.
> > >
> > > I got "uncompressing Linux 4.13" on serial console now, debug LEDs
> > > blinking, and if I use a flashlight, I see output on the screen, too.
> > >
> > > (What do I need to do to get the backlight working?)
> >
> > Glad you got it working :) For backlight you can add this
> > in drivers/gpu/drm/omapdrm/displays/panel-dsi-cm.c:
> >
> > add the following code at the end of dsicm_probe:
>
> You did not actually include code to paste into panel-dsi-cm, can you
> try a again?

I added it directly below and you quoted it. I guess you mistook it
for a signature or something :)

-- Sebastian

> > -----------------------------------------------------------
> > mutex_unlock(&ddata->lock);
> > mutex_lock(&ddata->lock);
> > ddata->in->ops.dsi->bus_lock(ddata->in);
> > r = dsicm_wake_up(ddata);
> > if (!r)
> > r = dsicm_dcs_write_1(ddata, DCS_BRIGHTNESS, 100);
> > ddata->in->ops.dsi->bus_unlock(ddata->in);
> > mutex_unlock(&ddata->lock);
> > -----------------------------------------------------------
> >
> > -- Sebastian
[unhandled content-type:application/pgp-signature]
\
 
 \ /
  Last update: 2017-10-26 14:01    [W:0.081 / U:6.040 seconds]
©2003-2017 Jasper Spaans. hosted at Digital OceanAdvertise on this site