lkml.org 
[lkml]   [2017]   [Oct]   [13]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH] staging: rtsx: Add support for RTS5260
On Fri, Oct 13, 2017 at 11:11:15AM +0100, Lee Jones wrote:
> On Fri, 13 Oct 2017, Greg KH wrote:
>
> > On Fri, Oct 13, 2017 at 10:54:22AM +0100, Lee Jones wrote:
> > > On Fri, 13 Oct 2017, Greg KH wrote:
> > >
> > > > On Fri, Oct 13, 2017 at 04:50:35PM +0800, rui_feng@realsil.com.cn wrote:
> > > > > From: rui_feng <rui_feng@realsil.com.cn>
> > > > >
> > > > > Add support for new chip rts5260.
> > > > > In order to support rts5260,the definitions of some internal
> > > > > registers and workflow have to be modified and are different from its
> > > > > predecessors and OCP function is added for RTS5260.
> > > > > So we need this patch to ensure RTS5260 can work.
> > > > >
> > > > > Signed-off-by: Rui Feng <rui_feng@realsil.com.cn>
> > > >
> > > > Your from and signed-off-by name does not match :(
> > > >
> > > > > ---
> > > > > drivers/mfd/Makefile | 4 +
> > > > > drivers/mfd/rtsx_pcr.c | 127 ++++++-
> > > > > drivers/mfd/rtsx_pcr.h | 12 +
> > > > > drivers/staging/Kconfig | 2 +
> > > > > drivers/staging/rts5260/Kconfig | 6 +
> > > > > drivers/staging/rts5260/rts5260.c | 748 ++++++++++++++++++++++++++++++++++++++
> > > > > drivers/staging/rts5260/rts5260.h | 45 +++
> > > > > include/linux/mfd/rtsx_pci.h | 234 +++++++++++-
> > > >
> > > > I do not see a reason why this is a staging driver. Where is the TODO
> > > > file listing what needs to be done to get it out of staging? Why can it
> > > > not just go into the "real" part of the kernel?
> > >
> > > It's not a staging driver. Rui's focus appears to be to have this
> > > driver accepted into Mainline by hook or by crock. He's tried MFD,
> > > Misc and now Staging!
> >
> > Yeah, I've watched it too :)
> >
> > > Background:
> > >
> > > There are a number of drivers in this family which currently reside in
> > > MFD. These were accepted before my time. After a recent review I've
> > > made the decision that these aren't MFD drivers at all.
> > >
> > > MFD drivers are ones which aid in registering and setting up shared
> > > resources for sub-devices which reside on the same piece of silicon.
> > > This driver does basically none of that. Instead it *is* the (what we
> > > describe above as) sub-device. It does everything.
> >
> > I agree with your assessment.
> >
> > > In the absence of a subsystem which covers this type of device, I
> > > suggested Misk as a good location to place these drivers.
>
> Sorry, that should have been "Misc"
>
> > What type of device is this thing? I can't seem to figure that out. If
> > we can determine that, then we can find the proper place for it in the
> > kernel.
>
> It's a card (MMC, (u)SD, etc) reader.

Ok, how does it hook up to the hardware to talk to the reader?

And we have other card readers in drivers/misc/ so maybe that is the
right place for it, depending on the api to the hardware.

thanks,

greg k-h

\
 
 \ /
  Last update: 2017-10-13 12:21    [W:0.052 / U:0.148 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site