lkml.org 
[lkml]   [2017]   [Jan]   [11]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
Subject[PATCH 00/18] MTD-CFI: Fine-tuning for several function implementations
Date
From: Markus Elfring <elfring@users.sourceforge.net>
Date: Wed, 11 Jan 2017 21:21:12 +0100

Several update suggestions were taken into account
from static source code analysis.

Markus Elfring (18):
Use kmalloc_array() in cfi_intelext_partition_fixup()
Improve another size determination in cfi_intelext_partition_fixup()
cfi_cmdset_0001: Add some spaces for better code readability
cfi_cmdset_0001: Delete an unnecessary variable initialisation in do_write_oneword()
cfi_cmdset_0001: Use common error handling code in do_write_oneword()
Use kcalloc() in cfi_intelext_setup()
One function call and an unnecessary check less in cfi_intelext_setup()
Rename a jump label in cfi_intelext_setup()
Use kmalloc_array() in cfi_amdstd_setup()
One function call less in cfi_amdstd_setup() after error detection
Rename a jump label in cfi_amdstd_setup()
cfi_cmdset_0002: Add some spaces for better code readability
cfi_cmdset_0002: Delete an unnecessary variable initialisation in do_write_oneword()
cfi_cmdset_0002: Use common error handling code in do_write_oneword()
Use kcalloc() in cfi_ppb_unlock()
Use kmalloc_array() in cfi_staa_setup()
Use common error handling code in cfi_staa_setup()
cfi_cmdset_0020: Add some spaces for better code readability

drivers/mtd/chips/cfi_cmdset_0001.c | 165 +++++++++++++++++++-----------------
drivers/mtd/chips/cfi_cmdset_0002.c | 110 +++++++++++++-----------
drivers/mtd/chips/cfi_cmdset_0020.c | 127 ++++++++++++++-------------
3 files changed, 214 insertions(+), 188 deletions(-)

--
2.11.0

\
 
 \ /
  Last update: 2017-01-11 21:39    [W:0.995 / U:0.252 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site