lkml.org 
[lkml]   [2017]   [Jan]   [10]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH 3/7] ALSA: hda - use dell_micmute_led_set() instead of dell_app_wmi_led_set()
> On Mon, 09 Jan 2017 14:26:31 +0100,
> Michał Kępień wrote:
> >
> > > > On Thu Dec 15 15:46:28 2016 Michał Kępień <kernel@kempniu.pl> wrote:
> > > > > > On Thursday 08 December 2016 13:36:14 Michał Kępień wrote:
> > > > > > > --- a/sound/pci/hda/dell_wmi_helper.c
> > > > > > > +++ b/sound/pci/hda/dell_wmi_helper.c
> > > > > > > @@ -6,7 +6,7 @@
> > > > > > > #include <linux/dell-led.h>
> > > > > > >
> > > > > > > static int dell_led_value;
> > > > > > > -static int (*dell_led_set_func)(int, int);
> > > > > > > +static int (*dell_led_set_func)(int);
> > > > > >
> > > > > > Suggestion: what about changing name to dell_micmute_led_set_func to
> > > > > > match real function name which is used after this patch?
> > > > >
> > > > > While I like the idea itself, implementing it will double the number of
> > > > > lines that this patch changes (6 vs. 12), arguably making its intention
> > > >
> > > > If some patch makes final result of code better then metric number of lines is not priority.
> > > >
> > > > > less clear.  Please let me know if you would really like this to happen
> > > > > (perhaps as a separate patch?), otherwise I will skip this idea in v2.
> > > > >
> > > > > --
> > > > > Best regards,
> > > > > Michał Kępień
> > > >
> > > > If it will be in this or another following patch... I dot care. But this is sound subsystem, so sound maintainers need to decide what they prefer.
> > >
> > > Good point. Jaroslav, Takashi, I will patiently wait for your opinion
> > > on this patch and Pali's suggestion quoted above before I post v2 of
> > > this series.
> >
> > As it has already been a month since I posted this patch series, this is
> > just a reminder that I am waiting for comments from the sound subsystem
> > maintainers before I post v2.
> >
> > Jaroslav, Takashi, I could really use your input. Please let me know if
> > something is unclear. Thanks,
>
> Sorry, the last post was overseen as I already went off to vacation.

No worries, thank you for getting back to me.

> The rename can be done in another patch. Doing multiple things in a
> single patch often leads to more confusion and error-prone.
>
> Other than that, I'm fine with rename.

Thank you for your comments, I will keep them in mind for v2.

--
Best regards,
Michał Kępień

\
 
 \ /
  Last update: 2017-01-10 06:30    [W:2.053 / U:0.332 seconds]
©2003-2017 Jasper Spaans. hosted at Digital OceanAdvertise on this site