lkml.org 
[lkml]   [2016]   [Aug]   [3]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
SubjectRE: [PATCH 0071/1285] Replace numeric parameter like 0444 with macro
Date
From: Baole Ni
> Sent: 02 August 2016 11:39
> I find that the developers often just specified the numeric value
> when calling a macro which is defined with a parameter for access permission.
> As we know, these numeric value for access permission have had the corresponding macro,
> and that using macro can improve the robustness and readability of the code,
> thus, I suggest replacing the numeric parameter with the macro.
...
> -module_param(debug, ulong, 0644);
> +module_param(debug, ulong, S_IRUSR | S_IWUSR | S_IRGRP | S_IROTH);
...

If you're as old as I am the octal constant is easier to read!

David

\
 
 \ /
  Last update: 2016-08-03 18:41    [W:0.121 / U:0.128 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site