lkml.org 
[lkml]   [2016]   [Aug]   [2]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
Patch in this message
/
From
Subject[PATCH 1077/1285] Replace numeric parameter like 0444 with macro
Date
I find that the developers often just specified the numeric value
when calling a macro which is defined with a parameter for access permission.
As we know, these numeric value for access permission have had the corresponding macro,
and that using macro can improve the robustness and readability of the code,
thus, I suggest replacing the numeric parameter with the macro.

Signed-off-by: Chuansheng Liu <chuansheng.liu@intel.com>
Signed-off-by: Baole Ni <baolex.ni@intel.com>
---
kernel/trace/ring_buffer_benchmark.c | 12 ++++++------
1 file changed, 6 insertions(+), 6 deletions(-)

diff --git a/kernel/trace/ring_buffer_benchmark.c b/kernel/trace/ring_buffer_benchmark.c
index 6df9a83..c7a495af1 100644
--- a/kernel/trace/ring_buffer_benchmark.c
+++ b/kernel/trace/ring_buffer_benchmark.c
@@ -33,11 +33,11 @@ static struct task_struct *consumer;
static unsigned long read;

static unsigned int disable_reader;
-module_param(disable_reader, uint, 0644);
+module_param(disable_reader, uint, S_IRUSR | S_IWUSR | S_IRGRP | S_IROTH);
MODULE_PARM_DESC(disable_reader, "only run producer");

static unsigned int write_iteration = 50;
-module_param(write_iteration, uint, 0644);
+module_param(write_iteration, uint, S_IRUSR | S_IWUSR | S_IRGRP | S_IROTH);
MODULE_PARM_DESC(write_iteration, "# of writes between timestamp readings");

static int producer_nice = MAX_NICE;
@@ -46,16 +46,16 @@ static int consumer_nice = MAX_NICE;
static int producer_fifo = -1;
static int consumer_fifo = -1;

-module_param(producer_nice, int, 0644);
+module_param(producer_nice, int, S_IRUSR | S_IWUSR | S_IRGRP | S_IROTH);
MODULE_PARM_DESC(producer_nice, "nice prio for producer");

-module_param(consumer_nice, int, 0644);
+module_param(consumer_nice, int, S_IRUSR | S_IWUSR | S_IRGRP | S_IROTH);
MODULE_PARM_DESC(consumer_nice, "nice prio for consumer");

-module_param(producer_fifo, int, 0644);
+module_param(producer_fifo, int, S_IRUSR | S_IWUSR | S_IRGRP | S_IROTH);
MODULE_PARM_DESC(producer_fifo, "fifo prio for producer");

-module_param(consumer_fifo, int, 0644);
+module_param(consumer_fifo, int, S_IRUSR | S_IWUSR | S_IRGRP | S_IROTH);
MODULE_PARM_DESC(consumer_fifo, "fifo prio for consumer");

static int read_events;
--
2.9.2
\
 
 \ /
  Last update: 2016-08-02 17:01    [W:0.034 / U:1.024 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site