lkml.org 
[lkml]   [2016]   [Jul]   [17]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH 1/2] x86/dumpstack: Optimize save_stack_trace
On Fri, Jul 08, 2016 at 10:22:46AM -0500, Josh Poimboeuf wrote:
> > > > Also, could you please rename the _norm names to _fast or so, to signal that this
> > > > is a faster but less reliable method to get a stack dump? Nobody knows what
> > > > '_norm' means, but '_fast' is pretty self-explanatory.
> > >
> > > Hm, but is print_context_stack_bp() variant really less reliable? From
> > > what I can tell, its only differences vs print_context_stack() are:
> > >
> > > - It doesn't scan the stack for "guesses" (which are 'unreliable' and
> > > are ignored by the ops->address() callback anyway).
> > >
> > > - It stops if ops->address() returns an error (which in this case means
> > > the array is full anyway).
> > >
> > > - It stops if the address isn't a kernel text address. I think this
> > > shouldn't normally be possible unless there's some generated code like
> > > bpf on the stack. Maybe it could be slightly improved for this case.
> > >
> > > So instead of adding a new save_stack_trace_fast() variant, why don't we
> > > just modify the existing save_stack_trace() to use
> > > print_context_stack_bp()?
> >
> > I'm not sure this is a good idea. First of all if the kernel isn't built with
> > frame pointers, all you have is wild walk guesses.
>
> True, though I'd argue that if frame pointers are disabled then
> save_stack_trace() should return an empty trace. But admittedly, that

As Frederic said, I think, some save_stack_trace() users may want to
check the 'guesses', in other words, it's not good idea for
save_stack_trace() to return an empty trace when frame pointers are
disabled. No?

> > There are several different users of save_stack_trace() in the kernel, we can't
> > be sure that all of them are interested in dropping those guesses.
> >
> > So I'd rather advocate in favour of a new seperate helper.
>
> So how about we change save_stack_trace() to use print_context_stack()
> for CONFIG_FRAME_POINTER=n and print_context_stack_bp() for
> CONFIG_FRAME_POINTER=y? That would preserve the existing behavior, no?

Even if CONFIG_FRAME_POINTER=y, someone may want to guess, doesn't they?

>
> --
> Josh

\
 
 \ /
  Last update: 2016-07-18 06:01    [W:0.057 / U:0.536 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site