lkml.org 
[lkml]   [2016]   [May]   [27]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH 1/2 v2] staging: dgnc: remove redundant NULL check for brd
On 27/05/16 02:42, Daeseok Youn wrote:
> the "brd" value cannot be NULL in dgnc_finalize_board_init().
> Because "brd" as a parameter of this function was already
> checked for NULL.
>
> the dgnc_finalize_board_init() as a static function was called
> only from dgnc_found_board() function and brd->magic value
> was assigned once in dgnc_found_board(). So it doesn't need to
> check for DGNC_BOARD_MAGIC value.
>
> Signed-off-by: Daeseok Youn <daeseok.youn@gmail.com>
> ---
> V2: Adds more comments to Change Log.
>
> drivers/staging/dgnc/dgnc_driver.c | 3 ---
> 1 file changed, 3 deletions(-)
>
> diff --git a/drivers/staging/dgnc/dgnc_driver.c b/drivers/staging/dgnc/dgnc_driver.c
> index af2e835..22257d2 100644
> --- a/drivers/staging/dgnc/dgnc_driver.c
> +++ b/drivers/staging/dgnc/dgnc_driver.c
> @@ -579,9 +579,6 @@ static int dgnc_finalize_board_init(struct dgnc_board *brd)
> {
> int rc = 0;
>
> - if (!brd || brd->magic != DGNC_BOARD_MAGIC)
> - return -ENODEV;
> -
> if (brd->irq) {
> rc = request_irq(brd->irq, brd->bd_ops->intr,
> IRQF_SHARED, "DGNC", brd);
>

Looks good.

Thanks for the fixes Daeseok :)

Luis

\
 
 \ /
  Last update: 2016-05-27 12:41    [W:0.352 / U:0.104 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site