lkml.org 
[lkml]   [2016]   [May]   [18]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH v2] locking/rwsem: Add reader-owned state to the owner field
On 05/18/2016 07:05 AM, Peter Zijlstra wrote:
> On Tue, May 17, 2016 at 12:46:07PM -0700, Paul E. McKenney wrote:
>> Actually, if you show a case where this makes a visible system-wide
>> difference, you could create a set of primitives for #1 below. Have
>> a compiler version check, and if it is an old compiler, map them to
>> READ_ONCE() and WRITE_ONCE(), otherwise as follows, though preferably
>> with better names:
>>
>> #define READ_NOTEAR(x) __atomic_load_n(&(x), __ATOMIC_RELAXED)
>> #define WRITE_NOTEAR(x, v) __atomic_store_n(&(x), (v), __ATOMIC_RELAXED)
>>
>> The ambiguity between "no tear" and "not ear" should help motivate a
>> better choice of name.
> Alternatively, could we try and talk to our GCC friends to make sure GCC
> doesn't tear loads/stores irrespective of what the C language spec
> allows?
>
>

Maybe the GCC guys can define a tag which can be set in the variable or
structure field declarations that those variables or field have to be
read from or written to atomically. This can allow critical data that
are used by multiple CPUs to be handled correctly while allowing
compiler the freedom to do what it sees fit for the less critical data.
This approach is also easier than looking for all the places where the
data items are accessed and modifying them.

Cheers,
Longman

\
 
 \ /
  Last update: 2016-05-18 18:21    [W:1.171 / U:0.372 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site