lkml.org 
[lkml]   [2016]   [Apr]   [4]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
    /
    SubjectRe: [PATCH v3 01/16] mm: use put_page to free page instead of putback_lru_page
    From
    Date


    On 30/03/16 18:12, Minchan Kim wrote:
    > Procedure of page migration is as follows:
    >
    > First of all, it should isolate a page from LRU and try to
    > migrate the page. If it is successful, it releases the page
    > for freeing. Otherwise, it should put the page back to LRU
    > list.
    >
    > For LRU pages, we have used putback_lru_page for both freeing
    > and putback to LRU list. It's okay because put_page is aware of
    > LRU list so if it releases last refcount of the page, it removes
    > the page from LRU list. However, It makes unnecessary operations
    > (e.g., lru_cache_add, pagevec and flags operations. It would be
    > not significant but no worth to do) and harder to support new
    > non-lru page migration because put_page isn't aware of non-lru
    > page's data structure.
    >
    > To solve the problem, we can add new hook in put_page with
    > PageMovable flags check but it can increase overhead in
    > hot path and needs new locking scheme to stabilize the flag check
    > with put_page.
    >
    > So, this patch cleans it up to divide two semantic(ie, put and putback).
    > If migration is successful, use put_page instead of putback_lru_page and
    > use putback_lru_page only on failure. That makes code more readable
    > and doesn't add overhead in put_page.
    So effectively when we return from unmap_and_move() the page is either
    put_page or putback_lru_page() and the page is gone from under us.


    \
     
     \ /
      Last update: 2016-04-04 08:41    [W:4.155 / U:0.092 seconds]
    ©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site