lkml.org 
[lkml]   [2016]   [Apr]   [25]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH] make dt_scan_depth1_nodes more readable
On Mon, Apr 25, 2016 at 11:25:11AM +0100, Stefano Stabellini wrote:
> From: Mark Rutland <mark.rutland@arm.com>
>
> Improve the readability of dt_scan_depth1_nodes by removing the nested
> conditionals.
>
> Signed-off-by: Mark Rutland <mark.rutland@arm.com>
> Signed-off-by: Stefano Stabellini <sstabellini@kernel.org>
>
> ---
>
> Note: this patch is based on xentip/for-linus-4.7

So how should I merge it? :/

Will

>
> diff --git a/arch/arm64/kernel/acpi.c b/arch/arm64/kernel/acpi.c
> index 57ee317..6884c76 100644
> --- a/arch/arm64/kernel/acpi.c
> +++ b/arch/arm64/kernel/acpi.c
> @@ -66,17 +66,24 @@ static int __init dt_scan_depth1_nodes(unsigned long node,
> void *data)
> {
> /*
> - * Return 1 as soon as we encounter a node at depth 1 that is
> - * not the /chosen node, or /hypervisor node with compatible
> - * string "xen,xen".
> + * Ignore anything not directly under the root node; we'll
> + * catch its parent instead.
> */
> - if (depth == 1 && (strcmp(uname, "chosen") != 0)) {
> - if (strcmp(uname, "hypervisor") != 0 ||
> - !of_flat_dt_is_compatible(node, "xen,xen"))
> - return 1;
> - }
> + if (depth != 1)
> + return 0;
>
> - return 0;
> + if (strcmp(uname, "chosen") == 0)
> + return 0;
> +
> + if (strcmp(uname, "hypervisor") == 0 &&
> + of_flat_dt_is_compatible(node, "xen,xen"))
> + return 0;
> +
> + /*
> + * This node at depth 1 is neither a chosen node nor a xen node,
> + * which we do not expect.
> + */
> + return 1;
> }
>
> /*
>

\
 
 \ /
  Last update: 2016-04-25 13:21    [W:0.036 / U:0.168 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site