lkml.org 
[lkml]   [2016]   [Mar]   [6]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
Patch in this message
/
From
Subject[PATCH 1/2] debugfs: fix DocBook comment of debugfs_use_file_start()
Date
In commit 055cd38ba671 ("debugfs: prevent access to possibly dead
file_operations at file open")
debugfs_use_file_start() has been introduced. Unfortunately, the associated
DocBook comment hasn't been updated to properly reflect the change of the
'file' argument into 'dentry' during the evolution of the aforementioned
patch.

Catch up on this and rename '@file' to '@dentry' in the DocBook comment
associated with debugfs_use_file_start().

Signed-off-by: Nicolai Stange <nicstange@gmail.com>
---
fs/debugfs/file.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/fs/debugfs/file.c b/fs/debugfs/file.c
index 1a03e99..6a4b667 100644
--- a/fs/debugfs/file.c
+++ b/fs/debugfs/file.c
@@ -50,7 +50,7 @@ const struct file_operations debugfs_noop_file_operations = {

/**
* debugfs_use_file_start - mark the beginning of file data access
- * @file: the file object whose data is being accessed.
+ * @dentry: the dentry object whose data is being accessed.
* @srcu_idx: a pointer to some memory to store a SRCU index in.
*
* Up to a matching call to debugfs_use_file_finish(), any
--
2.7.2
\
 
 \ /
  Last update: 2016-03-06 21:41    [W:0.467 / U:0.168 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site