lkml.org 
[lkml]   [2016]   [Mar]   [22]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
SubjectRe: [PATCH 4/5] mm/lru: is_file/active_lru can be boolean
From
Date
On Wed, 2016-03-23 at 10:26 +0800, Yaowei Bai wrote:
> This patch makes is_file/active_lru return bool to improve
> readability due to these particular functions only using either
> one or zero as their return value.
>
> No functional change.

These assignments to int should likely be modified too

$ git grep -w -n is_file_lru
include/linux/mmzone.h:191:static inline int is_file_lru(enum lru_list lru)
mm/vmscan.c:1404:                                   nr_taken, mode, is_file_lru(lru));
mm/vmscan.c:1525:                       int file = is_file_lru(lru);
mm/vmscan.c:1581:       int file = is_file_lru(lru);
mm/vmscan.c:1783:       int file = is_file_lru(lru);
mm/vmscan.c:1934:       if (is_file_lru(lru))
mm/vmscan.c:2129:                       int file = is_file_lru(lru);

\
 
 \ /
  Last update: 2016-03-23 04:41    [W:0.458 / U:0.136 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site