lkml.org 
[lkml]   [2016]   [Feb]   [18]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH v11 3/4] x86, mce: Add __mcsafe_copy()

* Peter Zijlstra <peterz@infradead.org> wrote:

> On Thu, Feb 18, 2016 at 09:21:07AM +0100, Ingo Molnar wrote:
> >
> > * Tony Luck <tony.luck@intel.com> wrote:
> >
> > > Make use of the EXTABLE_FAULT exception table entries. This routine
> > > returns a structure to indicate the result of the copy:
> >
> > So the series looks good to me, but I have some (mostly readability) comments that
> > went beyond what I usually fix up manually:
> >
> > > struct mcsafe_ret {
> > > u64 trapnr;
> > > u64 remain;
> > > };
> >
> > > +struct mcsafe_ret {
> > > + u64 trapnr;
> > > + u64 remain;
> > > +};
> >
> > Yeah, so please change this to something like:
> >
> > struct mcsafe_ret {
> > u64 trap_nr;
> > u64 bytes_left;
> > };
> >
> > this makes it crystal clear what the fields are about and what their unit is.
> > Readability is king and modern consoles are wide enough, no need to abbreviate
> > excessively.
>
> I prefer to use my modern console width to display multiple columns of
> text, instead of wasting it to display mostly whitespace. Therefore I
> still very much prefer ~80 char wide code.

This naming won't hurt the col80 limit.

> > Also, I'd suggest we postfix the new mcsafe functions with '_mcsafe', not
> > prefix them. Special properties of memcpy routines are usually postfixes -
> > such as _nocache(), _toio(), etc.
>
> I think the whole notion of mcsafe here is 'wrong'. This copy variant simply
> reports the kind of trap that happened (#PF or #MC) and could arguably be
> extended to include more types if the hardware were to generate more.

What would a better name be? memcpy_ret() or so?

Thanks,

Ingo

\
 
 \ /
  Last update: 2016-02-18 11:41    [W:0.200 / U:0.176 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site