lkml.org 
[lkml]   [2016]   [Feb]   [1]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH 11/14] USB: serial: mos7840: move constants to right
On Sun, Jan 31, 2016 at 10:33:54PM +0100, Bjørn Mork wrote:
> Mathieu OTHACEHE <m.othacehe@gmail.com> writes:
>
> > This patch fixes the following coccinelle warnings:
> >
> > drivers/usb/serial/mos7840.c:2042:4-10: Move constant to right.
> > drivers/usb/serial/mos7840.c:2062:16-22: Move constant to right.
> >
> > Signed-off-by: Mathieu OTHACEHE <m.othacehe@gmail.com>
> > ---
> > drivers/usb/serial/mos7840.c | 4 ++--
> > 1 file changed, 2 insertions(+), 2 deletions(-)
> >
> > diff --git a/drivers/usb/serial/mos7840.c b/drivers/usb/serial/mos7840.c
> > index 8ddc313..982a3fb 100644
> > --- a/drivers/usb/serial/mos7840.c
> > +++ b/drivers/usb/serial/mos7840.c
> > @@ -2039,7 +2039,7 @@ static int mos7810_check(struct usb_serial *serial)
> > /* Send the 1-bit test pattern out to MCS7810 test pin */
> > usb_control_msg(serial->dev, usb_sndctrlpipe(serial->dev, 0),
> > MCS_WRREQ, MCS_WR_RTYPE,
> > - (0x0300 | (((test_pattern >> i) & 0x0001) << 1)),
> > + ((((test_pattern >> i) & 0x0001) << 1) | 0x0300),
> > MODEM_CONTROL_REGISTER, NULL, 0, MOS_WDR_TIMEOUT);
> >
> > /* Read the test pattern back */
> > @@ -2059,7 +2059,7 @@ static int mos7810_check(struct usb_serial *serial)
> >
> > /* Restore MCR setting */
> > usb_control_msg(serial->dev, usb_sndctrlpipe(serial->dev, 0), MCS_WRREQ,
> > - MCS_WR_RTYPE, 0x0300 | mcr_data, MODEM_CONTROL_REGISTER, NULL,
> > + MCS_WR_RTYPE, mcr_data | 0x0300, MODEM_CONTROL_REGISTER, NULL,
> > 0, MOS_WDR_TIMEOUT);
> >
> > kfree(buf);
>
> I feel I'm missing something here, so I have to ask the stupid question:
> What could possibly be the benefit here? Is it faster? Safer? Easier
> to read?

I don't think it will be faster or safer, maybe easier to read. But the point is to remove the
warnings produced by the file scripts/coccinelle/misc/compare_const_fl.cocci when
running make coccicheck.

>
>
>
> Bjørn

\
 
 \ /
  Last update: 2016-02-01 13:21    [W:0.089 / U:0.132 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site