lkml.org 
[lkml]   [2016]   [Nov]   [29]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH v2 1/2] eeprom: Add IDT 89HPESx EEPROM/CSR driver
On Tue, Nov 29, 2016 at 10:24:12PM +0100, Greg KH <gregkh@linuxfoundation.org> wrote:
> On Wed, Nov 30, 2016 at 12:16:25AM +0300, Serge Semin wrote:
> > On Tue, Nov 29, 2016 at 08:37:50PM +0100, Greg KH <gregkh@linuxfoundation.org> wrote:
> > > On Tue, Nov 29, 2016 at 01:38:20AM +0300, Serge Semin wrote:
> > > > +struct idt_89hpesx_dev {
> > > > + u32 eesize;
> > > > + bool eero;
> > > > + u8 eeaddr;
> > > > +
> > > > + u8 inieecmd;
> > > > + u8 inicsrcmd;
> > > > + u8 iniccode;
> > > > +
> > > > + atomic_t csr;
> > > > +
> > > > + int (*smb_write)(struct idt_89hpesx_dev *, const struct idt_smb_seq *);
> > > > + int (*smb_read)(struct idt_89hpesx_dev *, struct idt_smb_seq *);
> > > > + struct mutex smb_mtx;
> > > > +
> > > > + struct i2c_client *client;
> > > > +
> > > > + struct bin_attribute *ee_file;
> > > > + struct dentry *csr_dir;
> > > > + struct dentry *csr_file;
> > > > +};
> > > > +#define to_pdev_kobj(__kobj) \
> > > > + dev_get_drvdata(container_of(__kobj, struct device, kobj))
> > >
> > > Is it a struct device, or a kobject? This is totally confusing to me.
> > >
> > > And can't you just use kobj_to_dev()?
> > >
> >
> > I just didn't know about kobj_to_dev() inline function. Totally agree that
> > container_of() should be replaced with it.
> > What does look confusing to you? Do you mean the name "to_pdev_kobj" of the
> > macro?
>
> Yes, the macro is odd. As you are doing two different things here, just
> spell it out in the code and use kobj_to_dev() to make it easier to
> read please.
>
> > > > +/*
> > > > + * eeprom_attribute - EEPROM sysfs-node attributes
> > > > + *
> > > > + * NOTE Size will be changed in compliance with OF node. EEPROM attribute will
> > > > + * be read-only as well if the corresponding flag is specified in OF node.
> > > > + */
> > > > +BIN_ATTR(eeprom, 0644, idt_sysfs_eeprom_read, idt_sysfs_eeprom_write,
> > > > + EEPROM_DEF_SIZE);
> > >
> > > static?
> > >
> > > And BIN_ATTR_RW()?
> > >
> > > thanks,
> > >
> > > greg k-h
> >
> > Of course it should be static. Thanks for noticing that.
> > But I intentionally utilized BIN_ATTR() instead of BIN_ATTR_RW(), because
> > the last one implies to define the read/write methods with names
> > "_name##_read"/"_name##_write", which totally get out of naming within the
> > driver source code.
>
> That's ok, use the names the macro wants you to, that's the best way,
> and it ensures that I don't have to audit your permissions are correct
> for the file.
>
> > To tell the truth macro BIN_ATTR_RW() isn't that popular in the
> > kernel.
>
> Yes, but it should be, I have patches floating around somewhere to fix
> almost all of these up.
>
> > Neither is BIN_ATTR() macro, but it suites my driver better than the
> > another one.
>
> a "raw" BIN_ATTR() shouldn't be used either, please use the _RW()
> variant.
>
> thanks,
>
> greg k-h

Agreed with all the notes. I will send patchset v3 within next hour.

Thanks,
-Sergey

\
 
 \ /
  Last update: 2016-11-29 22:48    [W:0.053 / U:0.172 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site