lkml.org 
[lkml]   [2016]   [Nov]   [28]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
SubjectRe: [PATCH 1/6] perf tool: Add time-based utility functions
From
Date
On 11/28/16 6:58 AM, Jiri Olsa wrote:
> On Fri, Nov 25, 2016 at 02:39:54PM -0700, David Ahern wrote:
>> From: David Ahern <dsahern@gmail.com>
>>
>> Add function to parse a user time string of the form <start>,<stop>
>> where start and stop are time in sec.nsec format. Both start and stop
>> times are optional.
>>
>> Add function to determine if a sample time is within a given time
>> time window of interest.
>>
>> Signed-off-by: David Ahern <dsahern@gmail.com>
>> ---
>> tools/perf/util/Build | 1 +
>> tools/perf/util/time-utils.c | 85 ++++++++++++++++++++++++++++++++++++++++++++
>> tools/perf/util/time-utils.h | 12 +++++++
>> 3 files changed, 98 insertions(+)
>> create mode 100644 tools/perf/util/time-utils.c
>> create mode 100644 tools/perf/util/time-utils.h
>>
>> diff --git a/tools/perf/util/Build b/tools/perf/util/Build
>> index 1dc67efad634..78f139978e7a 100644
>> --- a/tools/perf/util/Build
>> +++ b/tools/perf/util/Build
>> @@ -87,6 +87,7 @@ libperf-y += help-unknown-cmd.o
>> libperf-y += mem-events.o
>> libperf-y += vsprintf.o
>> libperf-y += drv_configs.o
>> +libperf-y += time-utils.o
>
> I think we should call it just time.c, it's already in 'util' directory

can't rename time-utils.h to time.h because the include will get confused with <time.h> and if the header is named time-utils.h why not keep the c-file as time-utils.c?

\
 
 \ /
  Last update: 2016-11-28 18:35    [W:0.193 / U:0.204 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site