lkml.org 
[lkml]   [2015]   [Sep]   [22]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH 2/2] kernel/trace_probe: is_good_name can be boolean
On Tue, 22 Sep 2015 21:43:13 +0800
Yaowei Bai <bywxiaobai@163.com> wrote:

> This patch makes is_good_name return bool to improve readability
> due to this particular function only using either one or zero as its
> return value.

This patch makes sense. I'll take it. Thanks!

-- Steve

>
> No functional change.
>
> Signed-off-by: Yaowei Bai <bywxiaobai@163.com>
> ---
> kernel/trace/trace_probe.h | 8 ++++----
> 1 file changed, 4 insertions(+), 4 deletions(-)
>
> diff --git a/kernel/trace/trace_probe.h b/kernel/trace/trace_probe.h
> index b98dee9..f6398db 100644
> --- a/kernel/trace/trace_probe.h
> +++ b/kernel/trace/trace_probe.h
> @@ -302,15 +302,15 @@ static nokprobe_inline void call_fetch(struct fetch_param *fprm,
> }
>
> /* Check the name is good for event/group/fields */
> -static inline int is_good_name(const char *name)
> +static inline bool is_good_name(const char *name)
> {
> if (!isalpha(*name) && *name != '_')
> - return 0;
> + return false;
> while (*++name != '\0') {
> if (!isalpha(*name) && !isdigit(*name) && *name != '_')
> - return 0;
> + return false;
> }
> - return 1;
> + return true;
> }
>
> static inline struct event_file_link *



\
 
 \ /
  Last update: 2015-09-22 16:21    [W:0.061 / U:0.724 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site