lkml.org 
[lkml]   [2015]   [Jul]   [1]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: RFC: kernel coding style: prefer array to &array[0] ?
On Wed, Jul 01, 2015 at 07:53:44AM -0700, Joe Perches wrote:
> On Wed, 2015-07-01 at 14:26 +0200, Julia Lawall wrote:
> > On Wed, 1 Jul 2015, Dan Carpenter wrote:
> > > On Wed, Jul 01, 2015 at 01:54:29PM +0200, Clemens Ladisch wrote:
> > > > Joe Perches wrote:
> > > > > It seems most in-kernel uses are 'array' rather than '&array[0]'
> > > > >
> > > > > Most of the time, using array is simpler to read than &array[0].
> > > > >
> > > > > Exceptions exists when addresses for consecutive members are
> > > > > used like func(&array[0], &array[1]);
> > > >
> > > > I use '&array[0]' when I want to get a pointer to a single object that
> > > > happens to be the first one in an array.
> > >
> > > Yeah. Of course, you're right. Otherwise it ends up confusing static
> > > checkers if you want the first element or the whole array.
>
> Right.
>
> > > > > Should this preference be put into checkpatch and/or CodingStyle?
>
> And checkpatch will have no idea what the prototype
> for any function is, so this transform is better left
> for smarter tools like coccinelle.
>
> The proper answer here is no.
>
> > > > How about the following low-hanging fruit?
> > > >
> > > > foo(..., &array[0], ARRAY_SIZE(array), ...)
> > >
> > > Yes, to this also. I doubt checkpatch.pl will find a meaningful number
> > > of these but doing that is annoying thing.
> >
> > Atcually, I find 236 of them, in 48 files.
>
> The uses I found:
>
> drivers/input/touchscreen nas a few

I got curious so I ran the proposed patch over drivers/input/touchscreen
and it produced the following gems:

CHECK: Using addressof array 'data' index [0] may be simpler as 'data'
#49: FILE: drivers/input/touchscreen/dynapro.c:49:
+#define DYNAPRO_GET_TOUCHED(data) (DYNAPRO_FORMAT_TOUCH_BIT & data[0])


CHECK: Using addressof array 'mtouch->data' index [0] may be simpler as
'mtouch->data'
#97: FILE: drivers/input/touchscreen/mtouch.c:97:
+ if (MTOUCH_FORMAT_TABLET_STATUS_BIT & mtouch->data[0])

... etc.


While below can be written as just "msg" in many cases when you parse
several fields in the structure the original is actually cleaner:

CHECK: Using addressof array 'msg' index [0] may be simpler as 'msg'
#38: FILE: drivers/input/touchscreen/ipaq-micro-ts.c:38:
+ be16_to_cpup((__be16 *) &msg[0]));

I'd be OK with changing cases like:

CHECK: Using addressof array 'buf' index [0] may be simpler as 'buf'
#232: FILE: drivers/input/touchscreen/zforce_ts.c:232:
+ return zforce_send_wait(ts, &buf[0], ARRAY_SIZE(buf));

Thanks.

--
Dmitry


\
 
 \ /
  Last update: 2015-07-02 01:01    [W:0.078 / U:0.348 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site