lkml.org 
[lkml]   [2015]   [Jun]   [18]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [RFC/INCOMPLETE 01/13] context_tracking: Add context_tracking_assert_state

* Paul E. McKenney <paulmck@linux.vnet.ibm.com> wrote:

> On Wed, Jun 17, 2015 at 11:41:14AM +0200, Ingo Molnar wrote:
> >
> > * Andy Lutomirski <luto@kernel.org> wrote:
> >
> > > This will let us sprinkle sanity checks around the kernel without
> > > making too much of a mess.
> > >
> > > Signed-off-by: Andy Lutomirski <luto@kernel.org>
> > > ---
> > > include/linux/context_tracking.h | 8 ++++++++
> > > 1 file changed, 8 insertions(+)
> > >
> > > diff --git a/include/linux/context_tracking.h b/include/linux/context_tracking.h
> > > index 2821838256b4..0fbea4b152e1 100644
> > > --- a/include/linux/context_tracking.h
> > > +++ b/include/linux/context_tracking.h
> > > @@ -57,6 +57,13 @@ static inline void context_tracking_task_switch(struct task_struct *prev,
> > > if (context_tracking_is_enabled())
> > > __context_tracking_task_switch(prev, next);
> > > }
> > > +
> > > +static inline void context_tracking_assert_state(enum ctx_state state)
> > > +{
> > > + rcu_lockdep_assert(!context_tracking_is_enabled() ||
> > > + this_cpu_read(context_tracking.state) == state,
> > > + "context tracking state was wrong");
> > > +}
> >
> > Please don't introduce assert() style debug check interfaces!
> >
> > (And RCU should be fixed too I suspect.)
>
> The thought is to rename rcu_lockdep_assert() to RCU_LOCKDEP_WARN()
> by analogy to WARN()? Easy to do if so! Or am I missing the point?

Yeah, and inverting the condition. Assuming the condition was assert()-style
inverted to begin with! :-)

and lockdep should be fixed too I suspect, lockdep_assert_held() was really a
poorly chosen name I suspect, it should be 'lockdep_check_held()' or so? It has
very little to do with the assert() interface.

Thanks,

Ingo


\
 
 \ /
  Last update: 2015-06-18 12:21    [W:0.224 / U:0.108 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site