lkml.org 
[lkml]   [2015]   [Apr]   [27]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH v6 01/26] IB/Verbs: Implement new callback query_transport()
On 4/27/2015 2:52 PM, ira.weiny wrote:
> On Mon, Apr 27, 2015 at 09:39:05AM +0200, Michael Wang wrote:
>>
>>
>> On 04/24/2015 05:12 PM, Liran Liss wrote:
>>>> From: linux-rdma-owner@vger.kernel.org [mailto:linux-rdma-
>>>>
>>> [snip]
>>>> a/include/rdma/ib_verbs.h b/include/rdma/ib_verbs.h index
>>>> 65994a1..d54f91e 100644
>>>> --- a/include/rdma/ib_verbs.h
>>>> +++ b/include/rdma/ib_verbs.h
>>>> @@ -75,10 +75,13 @@ enum rdma_node_type { };
>>>>
>>>> enum rdma_transport_type {
>>>> + /* legacy for users */
>>>> RDMA_TRANSPORT_IB,
>>>> RDMA_TRANSPORT_IWARP,
>>>> RDMA_TRANSPORT_USNIC,
>>>> - RDMA_TRANSPORT_USNIC_UDP
>>>> + RDMA_TRANSPORT_USNIC_UDP,
>>>> + /* new transport */
>>>> + RDMA_TRANSPORT_IBOE,
>>>
>>> Remove RDMA_TRANSPORT_IBOE - it is not a transport.
>>> ROCE uses IBTA transport.
>>>
>>> If any code should test for ROCE should invoke a specific helper, e.g., rdma_protocol_iboe().
>>> This is what you currently call "rdma_tech_iboe" is patch 02/26.
>>>
>>> I think that pretty much everybody agrees that rdma_protocol_*() is a better name than rdma_tech_*(), right?
>>> So, let's change this.
>>
>> Sure, sounds reasonable now, about the IBOE, we still need it to
>> separate the port support IB/ETH without the check on link-layer,
>> So what about a new enum on protocol type?
>>
>> Like:
>>
>> enum rdma_protocol {
>> RDMA_PROTOCOL_IB,
>> RDMA_PROTOCOL_IBOE,
>> RDMA_PROTOCOL_IWARP,
>> RDMA_PROTOCOL_USNIC_UDP
>> };
>>
>> So we could use query_protocol() to ask device provide the protocol
>> type, and there will be no mixing with the legacy transport type
>> anymore :-)
>
> I'm ok with that. I like introducing a unique namespace which is clearly
> different from the previous "transport" one.

I agree the word "transport" takes things into the weeds.

But on the topic of naming protocols, I've been wondering, is there
some reason that "IBOE" is being used instead of "RoCE"? The IBOE
protocol used to exist and is not the same as the currently
standardized RoCE, right?

Also wondering, why add "UDP" to USNIC, is there a different USNIC?

Naming multiple layers together seems confusing and maybe in the end
will create more code to deal with the differences. For example, what
token will RoCEv2 take? RoCE_UDP, RoCE_v2 or ... ?


\
 
 \ /
  Last update: 2015-04-28 02:41    [W:0.092 / U:22.760 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site