lkml.org 
[lkml]   [2015]   [Mar]   [4]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH v2 07/15] x86/lib/copy_user_64.S: Convert to ALTERNATIVE_2

* Ingo Molnar <mingo@kernel.org> wrote:

>
> * Borislav Petkov <bp@alien8.de> wrote:
>
> > From: Borislav Petkov <bp@suse.de>
> >
> > Use the asm macro and drop the locally grown version.
>
> > @@ -73,9 +49,11 @@ ENTRY(_copy_to_user)
> > jc bad_to_user
> > cmpq TI_addr_limit(%rax),%rcx
> > ja bad_to_user
> > + ALTERNATIVE_2 "jmp copy_user_generic_unrolled", \
> > + "jmp copy_user_generic_string", \
> > + X86_FEATURE_REP_GOOD, \
> > + "jmp copy_user_enhanced_fast_string", \
> > + X86_FEATURE_ERMS
>
> Btw., as a future optimization, wouldn't it be useful to patch this
> function at its first instruction, i.e. to have three fully functional
> copy_user_generic_ variants and choose to jmp to one of them in the
> first instruction of the original function?
>
> The advantage would be two-fold:
>
> 1) right now: smart microarchitectures that are able to optimize
> jump-after-jump (and jump-after-call) targets in their branch
> target cache can do so in this case, reducing the overhead of the
> patching, possibly close to zero in the cached case.

Btw., the x86 memset() variants are using this today, and I think this
is the most optimal jump-patching variant, even if it means a small
amount of code duplication between the copy_user variants.

Thanks,

Ingo


\
 
 \ /
  Last update: 2015-03-04 08:41    [W:0.895 / U:0.036 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site