lkml.org 
[lkml]   [2015]   [Mar]   [17]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH RFC 0/2] x86/fpu: avoid "xstate_fault" in xsave_user/xrestore_user
On Mon, Mar 16, 2015 at 11:37:44PM +0100, Quentin Casasnovas wrote:

...

> __user_insn("btl [var2], %0 \n\t",
> , /* no outputs, no need for dummy arg */
> SINGLE_ARG("r" (var1), [var2] "r" (var2)), /* two inputs */
> "cc");

So this becomes pretty unreadable IMO. And we shouldn't go nuts with
optimizing this and sacrifice readability a lot.

TBH, I'd much prefer:

if (static_cpu_has_safe(X86_FEATURE_XSAVEOPT)) {
check_insn(XSAVEOPT, ...);
return;
}

if (static_cpu_has_safe(X86_FEATURE_XSAVES)) {
check_insn(XSAVES);
return;
}

check_insn(XSAVE, ...)

which is pretty clear.

We can even go a step further and add a static_cpu_has_safe thing which
checks two features instead of one. The penalty we'd get is a single
inconditional JMP which in the face of XSAVE* is nothing.

--
Regards/Gruss,
Boris.

ECO tip #101: Trim your mails when you reply.
--


\
 
 \ /
  Last update: 2015-03-17 11:01    [W:0.197 / U:0.212 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site