lkml.org 
[lkml]   [2015]   [Feb]   [9]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
SubjectRe: [PATCH 3/6] drivers: usb: core: hcd.c: remove assignment of variables in if conditions.
From
2015-02-08 12:15 GMT+01:00 Sergei Shtylyov <sergei.shtylyov@cogentembedded.com>:
> Hello.
>
> On 2/8/2015 12:55 AM, Bas Peters wrote:
>
>> This patch removes assignment of variables in if conditions,
>> as specified in CodingStyle.
>
>
>> Signed-off-by: Bas Peters <baspeters93@gmail.com>
>> ---
>> drivers/usb/core/hcd.c | 15 ++++++++++-----
>> 1 file changed, 10 insertions(+), 5 deletions(-)
>
>
>> diff --git a/drivers/usb/core/hcd.c b/drivers/usb/core/hcd.c
>> index 11cee55..37c40d1 100644
>> --- a/drivers/usb/core/hcd.c
>> +++ b/drivers/usb/core/hcd.c
>
> [...]
>>
>> @@ -2733,7 +2736,8 @@ int usb_add_hcd(struct usb_hcd *hcd,
>> /* "reset" is misnamed; its role is now one-time init. the
>> controller
>> * should already have been reset (and boot firmware kicked off
>> etc).
>> */
>> - if (hcd->driver->reset && (retval = hcd->driver->reset(hcd)) < 0)
>> {
>> + retval = hcd->driver->reset(hcd);
>
>
> This will crash if 'hcd->driver->reset' is NULL (which is only checked
> below).
>
>> + if (hcd->driver->reset && retval < 0) {
>
>
> It wasn't equivalent change anyway as the right part of && is only
> executed if the left part is true.

I'll fix this and your other comments and resend.

>
> WBR, Sergei
>

With kind regards,

Bas


\
 
 \ /
  Last update: 2015-02-09 11:21    [W:0.039 / U:0.268 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site