lkml.org 
[lkml]   [2015]   [Dec]   [17]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
    /
    Date
    From
    SubjectRe: [PATCH -next] irqchip: renesas-h8s: Replace ctrl_outw/ctrl_inw with writew/readw
    On Wed, 16 Dec 2015 13:30:37 +0900,
    Guenter Roeck wrote:
    >
    > Commit 13ae42a3b1c1 ("h8300: Rename ctlr_out/in[bwl] to
    > raw_read/write[bwl]") changed the function names, but not all callers,
    > resulting in
    >
    > drivers/irqchip/irq-renesas-h8s.c: In function ‘h8s_disable_irq’:
    > drivers/irqchip/irq-renesas-h8s.c:43:9: error:
    > implicit declaration of function ‘ctrl_inw’
    > drivers/irqchip/irq-renesas-h8s.c:44:2: error:
    > implicit declaration of function ‘ctrl_outw’
    >
    > Fixes: 13ae42a3b1c1 ("h8300: Rename ctlr_out/in[bwl] to raw_read/write[bwl]")
    > Cc: Daniel Lezcano <daniel.lezcano@linaro.org>
    > Signed-off-by: Guenter Roeck <linux@roeck-us.net>

    Applied.
    Thanks.

    > ---
    > drivers/irqchip/irq-renesas-h8s.c | 10 +++++-----
    > 1 file changed, 5 insertions(+), 5 deletions(-)
    >
    > diff --git a/drivers/irqchip/irq-renesas-h8s.c b/drivers/irqchip/irq-renesas-h8s.c
    > index 8098ead1eb22..af8c6c61c824 100644
    > --- a/drivers/irqchip/irq-renesas-h8s.c
    > +++ b/drivers/irqchip/irq-renesas-h8s.c
    > @@ -40,8 +40,8 @@ static void h8s_disable_irq(struct irq_data *data)
    > addr = IPRA + ((ipr_table[irq - 16] & 0xf0) >> 3);
    > pos = (ipr_table[irq - 16] & 0x0f) * 4;
    > pri = ~(0x000f << pos);
    > - pri &= ctrl_inw(addr);
    > - ctrl_outw(pri, addr);
    > + pri &= readw(addr);
    > + writew(pri, addr);
    > }
    >
    > static void h8s_enable_irq(struct irq_data *data)
    > @@ -54,9 +54,9 @@ static void h8s_enable_irq(struct irq_data *data)
    > addr = IPRA + ((ipr_table[irq - 16] & 0xf0) >> 3);
    > pos = (ipr_table[irq - 16] & 0x0f) * 4;
    > pri = ~(0x000f << pos);
    > - pri &= ctrl_inw(addr);
    > + pri &= readw(addr);
    > pri |= 1 << pos;
    > - ctrl_outw(pri, addr);
    > + writew(pri, addr);
    > }
    >
    > struct irq_chip h8s_irq_chip = {
    > @@ -90,7 +90,7 @@ static int __init h8s_intc_of_init(struct device_node *intc,
    > /* All interrupt priority is 0 (disable) */
    > /* IPRA to IPRK */
    > for (n = 0; n <= 'k' - 'a'; n++)
    > - ctrl_outw(0x0000, IPRA + (n * 2));
    > + writew(0x0000, IPRA + (n * 2));
    >
    > domain = irq_domain_add_linear(intc, NR_IRQS, &irq_ops, NULL);
    > BUG_ON(!domain);
    > --
    > 2.1.4
    >

    --
    Yoshinori Sato
    <ysato@users.sourceforge.jp>


    \
     
     \ /
      Last update: 2015-12-17 18:01    [W:3.691 / U:0.004 seconds]
    ©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site