lkml.org 
[lkml]   [2015]   [Nov]   [18]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
SubjectRe: [PATCH v6 18/19] arm64:ilp32: change COMPAT_ELF_PLATFORM to report a a subplatform for ILP32
From
Date
Yury,

We had implemented gdb-support against the the earlier ILP32 incarnation.
I’ll take a look with the latest patch-set and see whether these still apply.

Best,
Philipp.

> On 18 Nov 2015, at 21:25, Yury Norov <ynorov@caviumnetworks.com> wrote:
>
> On Wed, Nov 18, 2015 at 03:21:05AM -0800, pinskia@gmail.com wrote:
>>
>>
>>> On Nov 18, 2015, at 12:11 AM, Zhangjian (Bamvor) <bamvor.zhangjian@huawei.com> wrote:
>>>
>>> Hi, Yury
>>>
>>>> On 2015/11/18 5:16, Yury Norov wrote:
>>>> From: Philipp Tomsich <philipp.tomsich@theobroma-systems.com>
>>>>
>>>> To make life for tools (such as gdb) easier when dealing with ILP32 processes,
>>>> we report a proper subarchitecture for ILP32 in the ELF auxiliary vectors.
>>> I saw some ilp32 relative patches in binutils mailing list. Does gdb
>>> fully support ilp32?
>>
>> I have a patch set but I have not tested them with the latest kernel patch set yet. The branch is located in the binutils-gdb git is https://sourceware.org/git/?p=binutils-gdb.git;a=shortlog;h=refs/heads/users/pinskia/gdb-aarch64-ilp32 .
>> I think it will mostly work except for core support might need to be changed slightly.
>>
>> Thanks,
>> Andrew
>>>
>
> Yes, it works mostly. I can read and modify text/data, set breakpoints
> etc.
>
>>> Regards
>>>
>>> Bamvor
>>>



\
 
 \ /
  Last update: 2015-11-18 23:21    [W:0.069 / U:10.536 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site