lkml.org 
[lkml]   [2014]   [Jul]   [24]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
SubjectRe: [PATCH net-next] net: filter: rename 'struct sock_filter_int' into 'struct bpf_insn'
From
On Thu, Jul 24, 2014 at 4:21 PM, Daniel Borkmann <dborkman@redhat.com> wrote:
> On 07/24/2014 11:26 PM, Alexei Starovoitov wrote:
>>
>> eBPF is used by socket filtering, seccomp and soon by tracing and
>> exposed to userspace, therefore 'sock_filter_int' name is not accurate.
>> Rename it to 'bpf_insn'
>>
>> Signed-off-by: Alexei Starovoitov <ast@plumgrid.com>
>> ---
>
> ...
>
>> #define BPF_ALU64_REG(OP, DST, SRC) \
>> - ((struct sock_filter_int) { \
>> + ((struct bpf_insn) { \
>
>
> ^^^ Please also fix up whitespacing here
> and all the other sections below.

you mean to align last \ with other lines?
sure. good point.


\
 
 \ /
  Last update: 2014-07-25 02:01    [W:0.044 / U:3.008 seconds]
©2003-2017 Jasper Spaans. hosted at Digital OceanAdvertise on this site