lkml.org 
[lkml]   [2014]   [Apr]   [28]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
SubjectRe: [PATCH v3 2/3] Input: gpio_keys - convert to use devm_*
From
Date
On Fri, 2014-04-25 at 21:43 -0700, Dmitry Torokhov wrote:
> On Fri, Apr 25, 2014 at 07:22:16PM +0300, Andy Shevchenko wrote:
> > This makes the error handling much more simpler than open-coding everything and
> > in addition makes the probe function smaller an tidier.

[]

> > - pdata = kzalloc(sizeof(*pdata) + nbuttons * (sizeof *button),
> > - GFP_KERNEL);
> > - if (!pdata) {
> > - error = -ENOMEM;
> > - goto err_out;
> > - }
> > + pdata = devm_kzalloc(dev, sizeof(*pdata), GFP_KERNEL);
> > + if (!pdata)
> > + return ERR_PTR(-ENOMEM);
> > +
> > + pdata->buttons = devm_kcalloc(dev, nbuttons, sizeof (*button),
> > + GFP_KERNEL);
> > + if (!pdata->buttons)
> > + return ERR_PTR(-ENOMEM);
>
> Why are we splitting the allocation in 2?

Just for logical distinguishing, but I'm okay with one allocation.

--
Andy Shevchenko <andriy.shevchenko@linux.intel.com>
Intel Finland Oy



\
 
 \ /
  Last update: 2014-04-28 12:01    [W:0.056 / U:1.560 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site