lkml.org 
[lkml]   [2013]   [Jul]   [24]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH] module: ppc64 module CRC relocation fix causes perf issues
On 07/23/2013 08:30:32 AM, Michael Ellerman wrote:
> On Fri, Jul 19, 2013 at 05:59:30PM -0500, Scott Wood wrote:
> > On 07/17/2013 11:00:45 PM, Anton Blanchard wrote:
> > >
> > >Hi Scott,
> > >
> > >> What specifically should I do to test it?
> > >
> > >Could you double check perf annotate works? I'm 99% sure it will
> but
> > >that is what was failing on ppc64.
> >
> > I'm not really sure what it's supposed to look like when "perf
> > annotate" works. It spits a bunch of unreadable[1]
> > dark-blue-on-black assembly code at me, all with "0.00 :" in the
> > left column.
> >
> > Oh, wait -- some lines have "100.00 : " on the left, in
> > even-more-unreadable dark-red-on-black.
> >
> > Apart from the annoying colors, is there anything specific I should
> > be looking for? Some sort of error message, or output that actually
> > makes sense?
>
> The colours look fine on my terminal, so I don't know what you've done
> there.

It probably looks better if the terminal is configured to have a light
background (which of course makes some other programs look worse), or
(as I noted) if you've got your monitor set to be very bright. I now
see that xfce4-terminal lets me redefine the standard colors, though,
so that should help.

> If you care you can use "--stdio" to use the plainer interface,
> though it still uses colours.
>
> That output looks fine in terms of the bug Anton was chasing. As far
> as
> only ever hitting one instruction that does look weird.

OK. I'll add "investigate weird e500 perf annotate results" to the
TODO list...

-Scott


\
 
 \ /
  Last update: 2013-07-24 21:41    [W:0.059 / U:9.108 seconds]
©2003-2017 Jasper Spaans. hosted at Digital OceanAdvertise on this site