lkml.org 
[lkml]   [2013]   [Jun]   [6]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
SubjectRe: [PATCH 3/6] keucr: migrate printk to dev_dbg/info/warn/err
From
Date
On Thu, 2013-06-06 at 18:10 +0200, Johannes Schilling wrote:
> From: Laura Lawniczak <laura.lawniczak@googlemail.com>
[]
> diff --git a/drivers/staging/keucr/init.c b/drivers/staging/keucr/init.c
[]
> @@ -19,13 +19,13 @@ int ENE_InitMedia(struct us_data *us)
[]
> - printk(KERN_INFO "MiscReg03 = %x\n", MiscReg03);
> + dev_info(&us->pusb_dev->dev, "MiscReg03 = %x\n", MiscReg03);

I suggest adding a few convenience macros to make
this a bit shorter and more likely to fit on a single
line without exceeding 80 cols.

Adding something like:

#define us_<level>(us, fmt, ...) \
dev_<level>(&us->pusb_dev->dev, fmt, ##__VA_ARGS__)

so these uses become

us_info(us, "MiscReg03\n", MiscReg03);

which is shorter and more readable.

> diff --git a/drivers/staging/keucr/smilsub.c b/drivers/staging/keucr/smilsub.c
[]
> @@ -214,7 +214,7 @@ int Ssfdc_D_ReadSect(struct us_data *us, BYTE *buf, BYTE *redundant)
>
> result = ENE_LoadBinCode(us, SM_RW_PATTERN);
> if (result != USB_STOR_XFER_GOOD) {
> - printk("Load SM RW Code Fail !!\n");
> + dev_err(&us->pusb_dev->dev, "Load SM RW Code Fail !!\n");

Also, there's no need to shout in the logs.
These are reported at KERN_ERR level, so using

us_err(us, "loading SM RW code failed\n")

would be fine.




\
 
 \ /
  Last update: 2013-06-06 20:41    [W:0.065 / U:0.040 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site