lkml.org 
[lkml]   [2013]   [Mar]   [28]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
Patch in this message
/
Date
From
SubjectRe: [PATCH 2/2] xhci: Rename SEGMENT_SIZE and SEGMENT_SHIFT as the former is used in a.out.h
Hi Dave,

I'm a little bit confused about your description for the second one.
Did you need to change the #defines names because they could conflict
with other drivers when the xHCI driver is built in? Or is there some
other point I'm missing?

Are these feature patches for 3.10, or bug fixes for 3.9? If they're
for 3.9, should they go into stable? My inclination is the first patch
shouldn't but I'm not sure about this one.

On Thu, Mar 28, 2013 at 06:48:35PM +0000, David Howells wrote:
> Rename SEGMENT_SIZE and SEGMENT_SHIFT as the former is used in a.out.h.
>
> Signed-off-by: David Howells <dhowells@redhat.com>
> cc: Sarah Sharp <sarah.a.sharp@linux.intel.com>
> cc: Greg Kroah-Hartman <gregkh@linuxfoundation.org>
> cc: linux-usb@vger.kernel.org
...
> --- a/drivers/usb/host/xhci.h
> +++ b/drivers/usb/host/xhci.h
> @@ -1234,8 +1234,8 @@ union xhci_trb {
> #define TRBS_PER_SEGMENT 64
> /* Allow two commands + a link TRB, along with any reserved command TRBs */
> #define MAX_RSVD_CMD_TRBS (TRBS_PER_SEGMENT - 3)
> -#define SEGMENT_SIZE (TRBS_PER_SEGMENT*16)
> -#define SEGMENT_SHIFT (ilog2(SEGMENT_SIZE))
> +#define TRB_SEGMENT_SIZE (TRBS_PER_SEGMENT*16)
> +#define TRB_SEGMENT_SHIFT (ilog2(TRB_SEGMENT_SIZE))

I would prefer an XHCI_ prefix instead of a TRB_ prefix. Segments are
comprised of TRBs, so my brain doesn't parse this well. :)

Thanks,
Sarah Sharp


\
 
 \ /
  Last update: 2013-03-28 21:42    [W:0.043 / U:0.168 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site