lkml.org 
[lkml]   [2012]   [Sep]   [18]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
SubjectRe: [PATCH 2/7] dw_dmac: fill optional encoded parameters in register structure
From
On Tue, Sep 18, 2012 at 12:25 PM, Andy Shevchenko
<andriy.shevchenko@linux.intel.com> wrote:
>> > +#define dma_raw_readl(addr, name) \
>> > + readl((addr) + offsetof(struct dw_dma_regs, name))
>> > +
>> > +#define dma_raw_writel(addr, name, val) \
>> > + writel((val), (addr) + offsetof(struct dw_dma_regs, name))
>> > +
>>
>> But why don't you use earlier defined readl/writel macros:
>> dma_readl and dma_writel?

> If you look at further patches, namely 3rd, the access to the register
> is needed before we allocate memory for the dw_dma structure.

Ok. If i am not wrong, such calls are only required once for below line:

dw_params = dma_raw_readl(regs, DW_PARAMS

dma_raw_writel() is not used and shouldn't be required in future too.
So remove it.
dma_raw_readl() is required but the name is a bit confusing... this
raw type is different
from raw_readl...

Can we name it dma_read_byaddr()?

to make it more explicit.

viresh


\
 
 \ /
  Last update: 2012-09-18 10:41    [W:0.568 / U:0.048 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site