lkml.org 
[lkml]   [2012]   [Aug]   [8]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [bisected] nouveau: "Failed to idle channel x" after resume
On Wed, Aug 08, 2012 at 08:00:21AM +0200, Sven Joachim wrote:
> On 2012-08-08 07:37 +0200, Ben Skeggs wrote:
>
> > On Mon, Aug 06, 2012 at 11:38:04PM +0300, Maxim Levitsky wrote:
> >> On Sat, 2012-08-04 at 17:41 +0300, Maxim Levitsky wrote:
> >> > On Mon, 2012-07-23 at 18:25 +0300, Aioanei Rares wrote:
> >> > > On Thu, Jul 5, 2012 at 11:24 PM, Martin Nyhus <martin.nyhus@gmx.com> wrote:
> >> > > >
> >> > > > On Mon, 11 Jun 2012 23:18:42 +0200 Martin Nyhus wrote:
> >> > > > > after resuming from suspend nouveau starts writing Failed to idle
> >> > > > > channel x (where x is 2 or 3) to the log and X appears to stop and
> >> > > > > then restart only to stop again. Starting Firefox after resuming
> >> > > > > triggers the bugs every time, and bisecting leads to 03bd6efa
> >> > > > > ("drm/nv50/fifo: use hardware channel kickoff functionality").
> >> > > >
> >> > > > Hi Ben,
> >> > > > I'm still seeing this bug with the latest from Linus
> >> > > > (v3.5-rc5-98-g9e85a6f) and linux-next (next-20120705).
> >> > > >
> >> > > > lspci output:
> >> > > > 01:00.0 VGA compatible controller: nVidia Corporation G86 [GeForce
> >> > > > 8400M GS] (rev a1)
> >> > > >
> >> > > > Sorry I haven't followed up on this earlier,
> >> > > > Martin
> >> > >
> >> > > I can confirm this with 3.5.0, Chromium and Arch Linux. It's a HP
> >> > > Pavilion laptop with a G86 [GeForce 8400 M GS] video card .
> >> > > Seems related to this bug:
> >> > > http://lists.freedesktop.org/archives/nouveau/2011-January/007358.html
> >> > > . If I can do anything else
> >> > > to help, I will be glad to.
> >> > Added nouveau@lists.freedesktop.org>
> >> >
> >> > I confirm the same issue here.
> >> > will try to do dig it.
> >> Nope,can't dig this :-(
> > Interestingly, this works just fine for me after the driver rework.
>
> Not for me on my GeForce 8500 GT, and I still cannot suspend more than
> once, subsequent attempts fail:
>
> ,----
> | Aug 8 07:49:16 turtle kernel: [ 91.697068] nouveau W[ PGRAPH][0000:01:00.0][0x0200502d][ffff880037be1d40] parent failed suspend, -16
> | Aug 8 07:49:16 turtle kernel: [ 91.697078] nouveau [ DRM][0000:01:00.0] resuming display...
> `----
Interesting. Were there any messages prior to that? I guess the the fifo
code detected a timeout when trying to save the graphics context, I have
I have other patches in my tree (I'll push them soon, tied up with other
work atm) that might help here.

>
> > I can confirm issues on G86 with 3.5/3.6-rc1 stock though. I'll
> > attempt to find a fix suitable for the non-reworked driver.
>
> Thanks. I'm currently stuck on 3.4 because of this problem.
Sorry about that!

Ben.

>
> Cheers,
> Sven


\
 
 \ /
  Last update: 2012-08-08 08:41    [from the cache]
©2003-2011 Jasper Spaans