[lkml]   [2012]   [Aug]   [8]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectRe: [rtc-linux] [PATCH 8/8] ARM: vt8500: gpio: Devicetree support for arch-vt8500
On Wed, Aug 8, 2012 at 11:19 AM, Arnd Bergmann <> wrote:

>> What on earth are all those magic numbers?
>> I *guess* they're enabling some default GPIO settings etc.
> No, they are the register offsets you quoted above, per bank.

Aha I was fooled by this:

+struct vt8500_gpio_bank_regs {
+ int en;
+ int dir;
+ int data_out;
+ int data_in;
+ int ngpio;
This needs to be named something intuitive like "vt8500_gpio_bank_regoffsets"

Some kerneldoc intsead of the opaque comment above will also improve
readability a lot:

* struct vt8500_gpio_bank_regoffsets
* @en: offset to enable register in the bank
* ...
Linus Walleij

 \ /
  Last update: 2012-08-08 17:02    [from the cache]
©2003-2014 Jasper Spaans. hosted at Digital Ocean