lkml.org 
[lkml]   [2012]   [Aug]   [7]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH 0/5] mfd: replace IORESOURCE_IO by IORESOURCE_MEM
On Tue, Aug 07, 2012 at 02:28:15PM +0000, Arnd Bergmann wrote:
> On Tuesday 07 August 2012, Mark Brown wrote:
> > As I said elsewhere 88pm* needs this as a stable bugfix and wm831x
> > should be converted over too.

> I've looked through the remaining MFD drivers and found one more,
> max8925-core, which is using IORESOURCE_IO for something that is
> not ISA/PCI IO-space.

Ah, yes - that's also used on Marvell platforms which presumably aren't
getting much mainline testing either.

> > > 2. Choosing a better name.

> > I'm not sure we need one, _REG seems perfectly fine here unless we want
> > to go with Arnd's suggestion of _OTHER. Do you have any concerns with
> > the use of reg?

> BenH actually suggested _OTHER. I think either one is fine.

Sorry Ben.

> Now I've looked at the three drivers with the immediate problem of
> IORESOURCE_IO abuse (max8925, wm831x, 88pm860x) and none of them are
> doing such bitmask operations, so I'm reasonably sure we are fine

Hopefully nobody will add this to the core code either. I wonder if
it's possible to change the definition of the constants for the resource
types so that they generate a warning if anyone does bitops on them...
that'd also get all the drivers fixed up eventually.

> for those drivers. I also agree that renumbering the resources in a
> way that makes it impossible to use bitmasks is a good idea, but
> that would actually be pretty invasive because then we have to rewrite
> all the functions that currently do it.

Yeah, that's why the new resource type has never been added - I don't
think anyone had considered the possibility of adding a new type without
also doing the renumbering, I know I didn't when I looked.


\
 
 \ /
  Last update: 2012-08-07 19:21    [from the cache]
©2003-2014 Jasper Spaans. Advertise on this site