lkml.org 
[lkml]   [2012]   [Aug]   [20]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH] Extcon: Minor change in the declaration of cable_names
> From: anish kumar <anish198519851985@gmail.com>
>
> Instead of "const char **supported_cable" it is better to have
> it as "const char *const *supported_cable".
>
> Signed-off-by: anish kumar <anish198519851985@gmail.com>

Could you please elaborate on why it's better?

(Is this fixing the using the standard naming issue Mark mentioned before?)


Cheers!
MyungJoo

> ---
> include/linux/extcon.h | 2 +-
> include/linux/extcon/extcon-adc-jack.h | 2 +-
> 2 files changed, 2 insertions(+), 2 deletions(-)
>
> diff --git a/include/linux/extcon.h b/include/linux/extcon.h
> index cdd4014..a6bcc29 100644
> --- a/include/linux/extcon.h
> +++ b/include/linux/extcon.h
> @@ -111,7 +111,7 @@ struct extcon_cable;
> struct extcon_dev {
> /* --- Optional user initializing data --- */
> const char *name;
> - const char **supported_cable;
> + const char *const *supported_cable;
> const u32 *mutually_exclusive;
>
> /* --- Optional callbacks to override class functions --- */
> diff --git a/include/linux/extcon/extcon-adc-jack.h b/include/linux/extcon/extcon-adc-jack.h
> index 20e9eef..f27f2e8 100644
> --- a/include/linux/extcon/extcon-adc-jack.h
> +++ b/include/linux/extcon/extcon-adc-jack.h
> @@ -60,7 +60,7 @@ struct adc_jack_pdata {
> /*
> * The last entry should be NULL
> */
> - const char **cable_names;
> + const char *const *cable_names;
> /* The last entry's state should be 0 */
> struct adc_jack_cond *adc_conditions;
>
> --
> 1.7.1
>
>
>
>
>
>
>
>
\
 
 \ /
  Last update: 2012-08-20 09:41    [from the cache]
©2003-2011 Jasper Spaans