lkml.org 
[lkml]   [2012]   [Jul]   [30]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
Subject[GIT PULL] SLAB changes for v3.6-rc0
Hi Linus,

Please pull the latest SLAB tree from:

git://git.kernel.org/pub/scm/linux/kernel/git/penberg/linux.git slab/next

Most of the changes included are from Christoph Lameter's "common slab"
patch series that unifies common parts of SLUB, SLAB, and SLOB
allocators. The unification is needed for Glauber Costa's "kmem memcg"
work that will hopefully appear for v3.7.

Rest of the changes are fixes and speedups by various people.

Pekka

------------------>
The following changes since commit f7da9cdf45cbbad5029d4858dcbc0134e06084ed:

Merge git://git.kernel.org/pub/scm/linux/kernel/git/davem/net (2012-07-28 06:00:39 -0700)

are available in the git repository at:

git://git.kernel.org/pub/scm/linux/kernel/git/penberg/linux.git slab/next

Andi Kleen (1):
slab/mempolicy: always use local policy from interrupt context

Christoph Lameter (21):
slub: Use freelist instead of "object" in __slab_alloc
slub: Add frozen check in __slab_alloc
slub: Acquire_slab() avoid loop
slub: Simplify control flow in __slab_alloc()
slub: new_slab_objects() can also get objects from partial list
slub: Get rid of the node field
slub: Separate out kmem_cache_cpu processing from deactivate_slab
slub: Use page variable instead of c->page.
slub: pass page to node_match() instead of kmem_cache_cpu structure
slob: Define page struct fields used in mm_types.h
slob: No need to zero mapping since it is no longer in use
slob: Remove various small accessors
slab: Use page struct fields instead of casting
slab: Remove some accessors
mm, sl[aou]b: Extract common fields from struct kmem_cache
slab: Get rid of obj_size macro
mm, sl[aou]b: Extract common code for kmem_cache_create()
mm, sl[aou]b: Common definition for boot state of the slab allocators
mm, sl[aou]b: Use a common mutex definition
mm, sl[aou]b: Move kmem_cache_create mutex handling to common code
slob: Fix early boot kernel crash

David Rientjes (1):
mm, slub: ensure irqs are enabled for kmemcheck

Feng Tang (1):
slab: Fix a typo in commit 8c138b "slab: Get rid of obj_size macro"

Glauber Costa (2):
slab: rename gfpflags to allocflags
slab: move FULL state transition to an initcall

Joonsoo Kim (2):
slub: use __cmpxchg_double_slab() at interrupt disabled place
slub: refactoring unfreeze_partials()

Julia Lawall (1):
slub: remove invalid reference to list iterator variable

Pekka Enberg (1):
Merge branch 'slub/cleanups' into slab/next

Shuah Khan (1):
mm: Fix build warning in kmem_cache_create()

Thierry Reding (1):
mm, slab: Build fix for recent kmem_cache changes

majianpeng (1):
mm: Fix signal SIGFPE in slabinfo.c.

include/linux/mempolicy.h | 2 +-
include/linux/mm_types.h | 11 +-
include/linux/slab.h | 24 +++
include/linux/slab_def.h | 12 +-
include/linux/slub_def.h | 3 +-
mm/Makefile | 3 +-
mm/mempolicy.c | 8 +-
mm/slab.c | 406 ++++++++++++++++--------------------------
mm/slab.h | 33 ++++
mm/slab_common.c | 120 +++++++++++++
mm/slob.c | 152 +++++-----------
mm/slub.c | 436 +++++++++++++++++++++------------------------
tools/vm/slabinfo.c | 14 +-
13 files changed, 608 insertions(+), 616 deletions(-)
create mode 100644 mm/slab.h
create mode 100644 mm/slab_common.c


\
 
 \ /
  Last update: 2012-07-30 15:01    [W:0.051 / U:0.980 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site