lkml.org 
[lkml]   [2012]   [Jul]   [11]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
    /
    From
    Subject[PATCH 0/9] staging: sm7xxfb: code improvements and cleanup
    Date
    From: "Javier M. Mellid" <jmunhoz@igalia.com>

    This patchset is part of the effort to get sm7xxfb in shape. It resolves
    some issues in functions related with mode setting and timing logic
    paths.

    The first 5 patches work on sm712vga_setup in order to get a more
    coherent and clear code.

    Patches 6 and 7 work on timing path. They rename sm712_set_timing
    together with the proper code relocation to ease reviewing and
    maintenance.

    Patch 8 erases a global variable. This patch moves pseudo palette into
    smtcfb_info.

    Patch 9 cleans on smtc_alloc_fb_info. This change looks for coherency
    with the rest of functions.

    Patches 3 and 5 warn about the same line going over 80 chars when
    checked with checkpatch. I think it makes sense going over 80 chars in
    this case since the readability improves.

    Tested with SM712.

    Javier M. Mellid (9):
    staging: sm7xxfb: fix struct names related to vesa modes
    staging: sm7xxfb: rename index var on sm712vga_setup
    staging: sm7xxfb: rename smtc_screen_info to smtc_scr_info
    staging: sm7xxfb: rename sm712vga_setup to sm7xx_vga_setup
    staging: sm7xxfb: minor maintenance on sm7xx_vga_setup
    staging: sm7xxfb: rename sm712_set_timing to sm7xx_set_timing
    staging: sm7xxfb: minor maintenance on timing path
    staging: sm7xxfb: move pseudo palette into smtcfb_info
    staging: sm7xxfb: cleanup on smtc_alloc_fb_info

    drivers/staging/sm7xxfb/sm7xxfb.c | 374 ++++++++++++++++++-------------------
    1 file changed, 183 insertions(+), 191 deletions(-)

    --
    1.7.10



    \
     
     \ /
      Last update: 2012-07-11 17:01    [W:2.812 / U:0.468 seconds]
    ©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site