lkml.org 
[lkml]   [2012]   [Jun]   [4]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH 01/27] smpboot: Provide a generic method to boot secondary processors
On 06/04/2012 04:02 PM, Thomas Gleixner wrote:

> On Sat, 2 Jun 2012, Srivatsa S. Bhat wrote:
>
>> On 06/01/2012 10:21 PM, Sam Ravnborg wrote:
>>
>>>> +/* Implement the following functions in your architecture, as appropriate. */
>>>> +
>>>> +/**
>>>> + * __cpu_pre_starting()
>>>> + *
>>>> + * Implement whatever you need to do before the CPU_STARTING notifiers are
>>>> + * invoked. Note that the CPU_STARTING callbacks run *on* the cpu that is
>>>> + * coming up. So that cpu better be prepared! IOW, implement all the early
>>>> + * boot/init code for the cpu here. And do NOT enable interrupts.
>>>> + */
>>>> +#ifndef __cpu_pre_starting
>>>> +void __weak __cpu_pre_starting(void *arg) {}
>>>> +#endif
>
> This wants to be a prototype w/o the __weak prefix and the #ifndef
> magic and the weak default implementation should be in kernel/smpboot.c
>


I can add the prototype w/o the __weak prefix and the #ifndef magic in
include/linux/smpboot.h (which I will, and include it in v2).

However, I can't get rid of the #ifndef magic in kernel/smpboot.c because
it will cause build failures on x86.

I addressed this same issue in another email:
https://lkml.org/lkml/2012/6/3/33

>>> __What __is __the __purpose __of __all __these __underscaores __used
>>> __as __function __prefix? __It __does __not __help __readability.
>>
>>>
>>
>>
>> We had used "__" as the function prefix to emphasize that these functions are
>> implemented/overriden in the depths of architecture-specific code.
>>
>> But now that you mention it, I see that we don't really have something like an
>> arch-independent variant without the "__" prefix. So adding the "__" prefix
>> might not be really necessary, since there is nothing to distinguish name-wise.
>>
>> However, I do want to emphasize that this isn't generic code. So how about
>> an "arch_" prefix instead? Something like:
>> arch_cpu_pre_starting(), arch_cpu_pre_online() and arch_cpu_post_online()?
>
> Yes, please.


Sure, queued up for v2. (Atm, figuring out how to deal with xen (patch 5). Once
that gets done, will post a v2.)

>
> Otherwise, thanks for that work!


We are glad that it helps :-)

> From the first glance, it's not
> colliding much with the changes I have in the pipeline, but I will
> have a closer look.
>


Great! Thanks a lot for your time, Thomas!

Regards,
Srivatsa S. Bhat



\
 
 \ /
  Last update: 2012-06-04 16:01    [W:0.133 / U:2.376 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site