lkml.org 
[lkml]   [2012]   [May]   [24]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
Date
SubjectRe: [git pull] Input updates for 3.5-rc0
On Thu, May 24, 2012 at 1:32 AM, Dmitry Torokhov
<dmitry.torokhov@gmail.com> wrote:
> Hi Linus,
>
> to receive updates for the input subsystem. You will get:

I get an annoying conflict, and the reason I call it annoying is not
because it's hard to resolve, it's because doing that shows that you
seem to have preferred using

dev_dbg(&input->dev.parent, ...)

over the much more natural

dev_dbg(&input->dev, ...)

which would seem to make more sense.

Why? Are the input layer device names so bad that using them for debug
output is useless? And if so, why *are* they so bad?

I'm going to take your version over Greg's more straightforward one,
because I assume Greg did things a bit more mindlessly and I think you
presumably had a *reason* for your extra (stupid) ".parent" part. But
I'm unhappy with it, because I suspect the reason you did that implies
that the input layer does something bad.

Hmm?

Linus


\
 
 \ /
  Last update: 2012-05-24 20:03    [W:0.236 / U:0.008 seconds]
©2003-2014 Jasper Spaans. Advertise on this site