lkml.org 
[lkml]   [2012]   [May]   [15]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
    Patch in this message
    /
    From
    Subject[PATCH v2 2/3] remove dependency with x86
    Date
    Exactly saying, [zram|zcache] should has a dependency with
    zsmalloc, not x86. So replace x86 dependeny with ZSMALLOC.
    Reviewed-by: Konrad Rzeszutek Wilk <konrad.wilk@oracle.com>
    Signed-off-by: Minchan Kim <minchan@kernel.org>
    ---
    drivers/staging/zcache/Kconfig | 3 +--
    drivers/staging/zram/Kconfig | 3 +--
    2 files changed, 2 insertions(+), 4 deletions(-)
    diff --git a/drivers/staging/zcache/Kconfig b/drivers/staging/zcache/Kconfig
    index 7048e01..ceb7f28 100644
    --- a/drivers/staging/zcache/Kconfig
    +++ b/drivers/staging/zcache/Kconfig
    @@ -2,8 +2,7 @@ config ZCACHE
    bool "Dynamic compression of swap pages and clean pagecache pages"
    # X86 dependency is because zsmalloc uses non-portable pte/tlb
    # functions
    - depends on (CLEANCACHE || FRONTSWAP) && CRYPTO=y && X86
    - select ZSMALLOC
    + depends on (CLEANCACHE || FRONTSWAP) && CRYPTO=y && ZSMALLOC
    select CRYPTO_LZO
    default n
    help
    diff --git a/drivers/staging/zram/Kconfig b/drivers/staging/zram/Kconfig
    index 9d11a4c..e3ac62d 100644
    --- a/drivers/staging/zram/Kconfig
    +++ b/drivers/staging/zram/Kconfig
    @@ -2,8 +2,7 @@ config ZRAM
    tristate "Compressed RAM block device support"
    # X86 dependency is because zsmalloc uses non-portable pte/tlb
    # functions
    - depends on BLOCK && SYSFS && X86
    - select ZSMALLOC
    + depends on BLOCK && SYSFS && ZSMALLOC
    select LZO_COMPRESS
    select LZO_DECOMPRESS
    default n
    --
    1.7.9.5


    \
     
     \ /
      Last update: 2012-05-16 04:41    [from the cache]
    ©2003-2011 Jasper Spaans