lkml.org 
[lkml]   [2012]   [Apr]   [25]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH 3/6] zsmalloc: rename zspage_order with zspage_pages
On 04/25/2012 10:03 PM, Nitin Gupta wrote:

> On 04/25/2012 02:23 AM, Minchan Kim wrote:
>
>> zspage_order defines how many pages are needed to make a zspage.
>> So _order_ is rather awkward naming. It already deceive Jonathan
>> - http://lwn.net/Articles/477067/
>> " For each size, the code calculates an optimum number of pages (up to 16)"
>>
>> Let's change from _order_ to _pages_.
>>
>> Signed-off-by: Minchan Kim <minchan@kernel.org>
>> ---
>> drivers/staging/zsmalloc/zsmalloc-main.c | 14 +++++++-------
>> drivers/staging/zsmalloc/zsmalloc_int.h | 2 +-
>> 2 files changed, 8 insertions(+), 8 deletions(-)
>>
>
>
> Recently, Seth changed max_zspage_order to ZS_MAX_PAGES_PER_ZSPAGE for
> the same reason. I think it would be better to rename the function in a
> similary way to have some consistency. So, we could use:
>
> 1) get_pages_per_zspage() instead of get_zspage_pages()
> 2) class->pages_per_zspage instead of class->zspage_pages
>


No problem. Will do.

--
Kind regards,
Minchan Kim


\
 
 \ /
  Last update: 2012-04-26 03:49    [from the cache]
©2003-2014 Jasper Spaans. Advertise on this site