lkml.org 
[lkml]   [2012]   [Apr]   [18]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
SubjectRe: 3.2.11: PCI Express card cannot be re-detected withing cca 60sec timeframe
From
On Wed, Apr 18, 2012 at 1:29 PM, Martin Mokrejs
<mmokrejs@fold.natur.cuni.cz> wrote:
> Yinghai Lu wrote:
>> On Wed, Apr 18, 2012 at 10:53 AM, Martin Mokrejs
>> <mmokrejs@fold.natur.cuni.cz> wrote:
>>>> After you remove USB3 expresscard, you need to
>>>>
>>>> echo 1 > /sys/devices/pci0000\:00/0000\:00\:1c.7/pcie_link_disable
>>>> then
>>>> echo 0 > /sys/devices/pci0000\:00/0000\:00\:1c.7/pcie_link_disable
>>>
>>> So without these two echo commands the is no improvement/fix.
>>>
>>> [  686.701306] pciehp 0000:00:1c.7:pcie04: pcie_isr: intr_loc 8
>>> [  686.701316] pciehp 0000:00:1c.7:pcie04: Presence/Notify input change
>>> [  686.701319] pciehp 0000:00:1c.7:pcie04: Card present on Slot(7)
>>> [  686.701357] pciehp 0000:00:1c.7:pcie04: Surprise Removal
>>> [  686.701390] pciehp 0000:00:1c.7:pcie04: check_link_active: lnk_status = 7011
>>> [  686.809763] pciehp 0000:00:1c.7:pcie04: pciehp_check_link_status: lnk_status = 7011
>> ...
>>> [  686.833678] hub 6-0:1.0: 2 ports detected
>>>
>>> echo 1 > /sys/devices/pci0000\:00/0000\:00\:1c.7/pcie_link_disable
>>>
>>> [  716.999938] pcieport 0000:00:1c.7: pcie_link_disable_set: lnk_ctrl = 53
>>> [  717.024647] pciehp 0000:00:1c.7:pcie04: pcie_isr: intr_loc 8
>>> [  717.024657] pciehp 0000:00:1c.7:pcie04: Presence/Notify input change
>>> [  717.024665] pciehp 0000:00:1c.7:pcie04: Card not present on Slot(7)
>>> [  717.024723] pciehp 0000:00:1c.7:pcie04: Surprise Removal
>>> [  717.024753] pciehp 0000:00:1c.7:pcie04: Disabling domain:bus:device=0000:11:00
>>> [  717.024756] pciehp 0000:00:1c.7:pcie04: pciehp_unconfigure_device: domain:bus:dev = 0000:11:00
>> ..
>>> [  717.045197] pci 0000:11:00.0: freeing pci_dev info
>>>
>>> echo 0 > /sys/devices/pci0000\:00/0000\:00\:1c.7/pcie_link_disable
>>>
>>> [  748.456914] pcieport 0000:00:1c.7: pcie_link_disable_set: lnk_ctrl = 40
>>>
>>
>> so it is chipset problem, it does not detect and report the presence
>> of the card after that link is removed.
>
> Why doesn't this happen with the FireWire express card?

sometimes it report correctly. sometime it does not.

>
>>
>> Can you try to use acpiphp instead of pciehp?
>
> Umm. I do have acpiphp in my kernel already. I am rather attaching my .config,
> please me know what you want me to do. My kernel command line could be seen
> in my previous posts in the dmesg file.

remove

CONFIG_HOTPLUG_PCI_PCIE=y
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2012-04-18 23:39    [from the cache]
©2003-2014 Jasper Spaans. Advertise on this site