lkml.org 
[lkml]   [2012]   [Mar]   [10]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
Patch in this message
/
From
Subject[PATCH 1/1] ata: AT91 ata driver requires specific platforms
Date
From: Arnd Bergmann <arnd@arndb.de>

This driver uses registers defined in a per-soc header file.
Since not every soc in the at91 platform defines those, make
the Kconfig option dependent on specifically the socs that
do.

Signed-off-by: Arnd Bergmann <arnd@arndb.de>
Signed-off-by: Alan Ott <alan@signal11.us>
---
drivers/ata/Kconfig | 1 +
1 files changed, 1 insertions(+), 0 deletions(-)
diff --git a/drivers/ata/Kconfig b/drivers/ata/Kconfig
index 6bdedd7..16c6b78 100644
--- a/drivers/ata/Kconfig
+++ b/drivers/ata/Kconfig
@@ -731,6 +731,7 @@ config PATA_AT32
config PATA_AT91
tristate "PATA support for AT91SAM9260"
depends on ARM && ARCH_AT91
+ depends on ARCH_AT91SAM9260 || ARCH_AT91SAM9G20 || ARCH_AT91SAM9261 || ARCH_AT91SAM9G10 || ARCH_AT91SAM9263 || ARCH_AT91SAM9RL || ARCH_AT91SAM9G45 || ARCH_AT91CAP9
help
This option enables support for IDE devices on the Atmel AT91SAM9260 SoC.

--
1.7.0.4


\
 
 \ /
  Last update: 2012-03-10 19:57    [from the cache]
©2003-2014 Jasper Spaans. Advertise on this site