lkml.org 
[lkml]   [2012]   [Feb]   [8]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
    /
    Date
    Subjectdrivers/net/phy/phy.c issue
    From
    Hi

    I found an issue with drivers/net/phy/phy.c
    As I could not identify a maintainer for this file I decided to mail
    it to the above addressees.
    Apologies upfront if it is inappropriate.

    The issue:

    My network interface was configured as 10Mbit, full duplex, autonegotiate off.
    If the cable is unplugged after 10 seconds or so the interface drops
    to half duplex and the message:
    Trying 10/HALF
    is printed. This message comes (if I am correct from the function
    phy_force_reduction in drivers/net/phy/phy.c

    Maybe this is still ok, however if I reconnect my network cable the
    interface remains configured as 10 Mbit, half duplex.
    I had expected/assumed that it would go back to 10 Mbit, full duplex.

    If I try the same with a 1Gbit full duplex link with autonegotiate on,
    the link also drops to half duplex whenever the cable is
    disconnected. However reconnecting the cable then brings the interface
    back to full duplex again.

    Not sure what is wrong (if the interface should not be dropped to half
    or get back to full) and even less an idea how to fix it,
    but wanted to report it anyway, in the hope someone can shed a light
    on this and/or fix it.

    Best regards, Frans.

    PS: I'm not on lkml (way too much mails for me), so please keep me on Cc


    \
     
     \ /
      Last update: 2012-02-08 15:33    [W:0.035 / U:91.792 seconds]
    ©2003-2016 Jasper Spaans. hosted at Digital OceanAdvertise on this site